• 4194阅读
  • 34回复

[易语言]梦幻西游脚本E语言源码下载 [复制链接]

上一主题 下一主题
离线黑猫

 
发帖
2416

只看楼主 道具中心使用道具 楼主  发表于: 2012-03-11
.版本 2 \0bao<  
.子程序 __启动窗口_创建完毕 N>a. dYXr  
提升进程权限 () <V?csx/eRd  
进程ID = 取进程ID (“my.exe”) K9z 1'k QH  
hwnd = 1903088 Vc2 (R^  
.子程序 取小二坐标, 逻辑型 |j2b=0Rpk  
.参数 坐标, 坐标型 (3. B\8s  
.局部变量 存储内存内容, 整数型, , "0" C_5o&O8Bc  
.局部变量 读坐标_计次, 整数型 10gh4,z[  
输出调试文本 (十到十六 (小二坐标 - 116)) nr*nX  
.如果真 (取反 (小二坐标 = 0 或 读内存整数型 (进程ID, 小二坐标) = 0)) 8D]&wBR:  
    坐标.x = 读内存整数型 (进程ID, 小二坐标) ÷ 20 #3 ~#`&  
    坐标.y = 四舍五入 ((1000 - 读内存整数型 (进程ID, 小二坐标 + 4)) ÷ 25, ) ^Kbq.4  
    返回 (真) @XJzM]*w&  
.如果真结束 '?gF9:  
内存搜索 (进程ID, 到字节集 (536871319), 存储内存内容) v.Vd js  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) [}+h86:y  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) 2h;#BJ))  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 116) BE$Wj;Q  
        .如果真 (取反 (坐标.x = 0)) &m PR[{  
            坐标.x = 坐标.x ÷ 20  k00&+C  
            坐标.y = 四舍五入 ((1000 - 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 120)) ÷ 25, ) vB?(|  
            小二坐标 = 存储内存内容 [读坐标_计次] + 116 [<nmJ-V  
            返回 (真) 6Cpn::WW}  
        .如果真结束 C#l9MxZE  
    .如果真结束 F'^y?UP[  
.计次循环尾 () SHA6;y+U/~  
返回 (假) j>I.d+   
.子程序 取驿站坐标, 逻辑型 Io*mFa?  
.参数 坐标, 坐标型, 可空 qX"m"ko  
.局部变量 存储内存内容, 整数型, , "0" Xw'Y &!z  
.局部变量 读坐标_计次, 整数型 _8{6&AmIw  
输出调试文本 (十到十六 (驿站坐标 - 116)) CkeqK  
.如果真 (取反 (驿站坐标 = 0)) d%lwg~@&|5  
    坐标.x = 读内存整数型 (进程ID, 驿站坐标) b8O }XB  
    坐标.y = 读内存整数型 (进程ID, 驿站坐标 + 4) +'`I]K>  
    返回 (真) 1 F+$\fLr  
.如果真结束 *USzzLq  
内存搜索 (进程ID, 到字节集 (536870914), 存储内存内容) +9NI=s6  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) {SJnPr3R  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) {^N90,!  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 116) ,0^9VWZV  
        坐标.y = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 120) V5up/6b,1  
        驿站坐标 = 存储内存内容 [读坐标_计次] + 116 "SFs\] Z  
        返回 (真) fK1^fzV  
    .如果真结束 LT:*K!>NOL  
.计次循环尾 ()  rT!9{uK  
返回 (假) Mw{skK>b  
.子程序 置驿站坐标 W}.p,d  
.参数 x I%# e\  
.参数 y QMBV"E_aY  
写内存整数型 (进程ID, 驿站坐标, x) a^MR"i>@G  
写内存整数型 (进程ID, 驿站坐标 + 4, y) nk+*M9r|I  
.子程序 取人物坐标, 逻辑型 5%%A2FrB.S  
.参数 坐标, 坐标型, 可空 O\[Td  
.局部变量 存储内存内容, 整数型, , "0" >a5avSn  
.局部变量 读坐标_计次, 整数型  i'NN  
' 输出调试文本 (十到十六 (人物坐标 - 168)) %{K6   
.如果真 (取反 (人物坐标 = 0)) )`gE-udR  
    坐标.x = 读内存整数型 (进程ID, 人物坐标) _<P~'IN+n  
    .如果真 (取反 (坐标.x = 0)) !Knv/:+  
        坐标.y = 读内存整数型 (进程ID, 人物坐标 + 4) ^"\., Y  
        返回 (真) (!&g (l;  
    .如果真结束 8L}N,6gC4_  
.如果真结束 rXR}]|;>  
内存搜索 (进程ID, 到字节集 (#角色ID), 存储内存内容) w=H4#a?fc  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) >5!/&D.q  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) -!p -nk@9|  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 168) 3` aJ"qQE  
        坐标.y = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 172) 5cE!'3Y  
        人物坐标 = 存储内存内容 [读坐标_计次] + 168 Fttny]  
        人物像素坐标 = 存储内存内容 [读坐标_计次] + 116 \w=7L- 8  
        返回 (真) 'd@Vusq}2  
    .如果真结束 n!(g<"  
.计次循环尾 () T\ h_8  
返回 (假) CQcb !T  
.子程序 取人物状态, 逻辑型 :`ysq  
.如果真 (人物坐标 = 0) D|D1`CIM  
    取人物坐标 () J}.y+b>8\  
.如果真结束 = *A_{u;E  
.如果真 (读内存整数型 (进程ID, 人物坐标 - 56) = 3) E4'D4@\W  
    返回 (真) ^JMSe-  
.如果真结束 VM3H&$d(h  
返回 (假) []Z| *+=Q  
.子程序 取地图编号, 整数型 *X;g Y  
.局部变量 存储内存内容, 整数型, , "0" >gr6H1  
.局部变量 读坐标_计次, 整数型 B!le=V,@,  
.如果真 (取反 (地图编号 = 0)) FK#>E[[  
    返回 (读内存整数型 (进程ID, 地图编号)) EVj48  
.如果真结束 00G[ `a5  
内存搜索 (进程ID, 到字节集 (288056328), 存储内存内容) V]PTAhc  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) Te> 7I  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 60) = 288056308) j86s[Dty  
        地图编号 = 存储内存内容 [读坐标_计次] + 60 j<+iL]b  
        返回 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 60)) 2+GF:[$  
    .如果真结束 (cYc03"  
.计次循环尾 () 4:<0i0)5  
返回 (0) &nn.h@zje  
附件设置隐藏,需要回复后才能看到!
离线殇情

只看楼主 沙发  发表于: 2012-03-12
谢谢分享~~~~~~~~~~~~~~~···
离线myredns

只看楼主 板凳  发表于: 2012-03-13
            
离线q846121931

只看楼主 地板  发表于: 2012-03-14
学习
离线zxccxzzxc

只看楼主 4楼 发表于: 2012-04-17
有意思~!!!!
离线xiao水滴

只看楼主 5楼 发表于: 2012-04-17
无名社区 —打造专业游戏论坛 取小二坐标 SF0Jb"kS  
5Lw{0uLr  
学习下 支持·······················
-------------------------
离线五渡

只看楼主 6楼 发表于: 2012-05-02
学习支持一下
离线supergirl520

发帖
11
只看楼主 7楼 发表于: 2012-05-08
学习学些。。。
离线hnscxh2012

只看楼主 8楼 发表于: 2012-05-28
强大,学学习习
离线deqdoff

只看楼主 9楼 发表于: 2012-06-04
Re:梦幻西游脚本E语言源码下载
快速回复
限80 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个