• 4353阅读
  • 35回复

[易语言]梦幻西游脚本E语言源码下载 [复制链接]

上一主题 下一主题
离线黑猫

 
发帖
2415

只看楼主 道具中心使用道具 楼主  发表于: 2012-03-11
.版本 2 J]\^QMX  
.子程序 __启动窗口_创建完毕 o#}mkE87  
提升进程权限 () Ja [#[BJ?  
进程ID = 取进程ID (“my.exe”) !*bdG(pK  
hwnd = 1903088 FmI;lVF0j  
.子程序 取小二坐标, 逻辑型 ^c'f<<z|7r  
.参数 坐标, 坐标型 j@t{@Ke  
.局部变量 存储内存内容, 整数型, , "0" (9'be\  
.局部变量 读坐标_计次, 整数型 vZk9gGjk  
输出调试文本 (十到十六 (小二坐标 - 116)) )_Iz>)  
.如果真 (取反 (小二坐标 = 0 或 读内存整数型 (进程ID, 小二坐标) = 0)) 4if\5P:j  
    坐标.x = 读内存整数型 (进程ID, 小二坐标) ÷ 20 xB,/dMdTj  
    坐标.y = 四舍五入 ((1000 - 读内存整数型 (进程ID, 小二坐标 + 4)) ÷ 25, ) PW)8aLU  
    返回 (真) cNeiD@t3V&  
.如果真结束 !ew6 n I  
内存搜索 (进程ID, 到字节集 (536871319), 存储内存内容) kQ[Jo%YT?E  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) WG\Q5k4Ba  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) 6VFirLd  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 116) !mae^A1  
        .如果真 (取反 (坐标.x = 0)) MYu`c[$jZ  
            坐标.x = 坐标.x ÷ 20 SctJxY(}!  
            坐标.y = 四舍五入 ((1000 - 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 120)) ÷ 25, ) 8W@dtZ,d  
            小二坐标 = 存储内存内容 [读坐标_计次] + 116 $':JI#  
            返回 (真) Nuo^+z E   
        .如果真结束 e`;t<7*i  
    .如果真结束 9u?Eb~#$  
.计次循环尾 () U Q)!|@&  
返回 (假) L7<+LA)s0  
.子程序 取驿站坐标, 逻辑型 ]  ~'9  
.参数 坐标, 坐标型, 可空 m[W/j/$A+x  
.局部变量 存储内存内容, 整数型, , "0" 6-tiRk~  
.局部变量 读坐标_计次, 整数型 hRa\1Jt>a  
输出调试文本 (十到十六 (驿站坐标 - 116)) z+ uL "PG[  
.如果真 (取反 (驿站坐标 = 0)) p%tE v  
    坐标.x = 读内存整数型 (进程ID, 驿站坐标) LNaeB(z"  
    坐标.y = 读内存整数型 (进程ID, 驿站坐标 + 4) Bpm,mp4g\#  
    返回 (真) R9Ldl97'  
.如果真结束 8~;{xYN )  
内存搜索 (进程ID, 到字节集 (536870914), 存储内存内容) 1k$2LQ  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) ' J2ewW5  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) UE\%e9<l  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 116) U[IQ1AEr  
        坐标.y = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 120) [+y &HNf  
        驿站坐标 = 存储内存内容 [读坐标_计次] + 116 keae.6[  
        返回 (真) /g13X,.H  
    .如果真结束 j[_t6Z  
.计次循环尾 () u.$Ym  
返回 (假) 3gC\{y!8  
.子程序 置驿站坐标 ThjUiuWe  
.参数 x fKFnCng  
.参数 y q s v+.aW  
写内存整数型 (进程ID, 驿站坐标, x) DxE(9j  
写内存整数型 (进程ID, 驿站坐标 + 4, y) s[Y)d>~\$=  
.子程序 取人物坐标, 逻辑型 W/b"a?wE{  
.参数 坐标, 坐标型, 可空 d^ 2u}^kG  
.局部变量 存储内存内容, 整数型, , "0" W/#KX}4  
.局部变量 读坐标_计次, 整数型 kJHr&=VO~  
' 输出调试文本 (十到十六 (人物坐标 - 168)) >.a+:   
.如果真 (取反 (人物坐标 = 0)) 29&sydu  
    坐标.x = 读内存整数型 (进程ID, 人物坐标) s]$HkSH  
    .如果真 (取反 (坐标.x = 0)) $Sp*)A]E`  
        坐标.y = 读内存整数型 (进程ID, 人物坐标 + 4) k\sc }z8X  
        返回 (真) Dm7Y#)%8  
    .如果真结束 %4?SY82  
.如果真结束 Yh}zt H  
内存搜索 (进程ID, 到字节集 (#角色ID), 存储内存内容) clh3  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) 2#>$%[   
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) y0/WA4,  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 168) ZA *b9W  
        坐标.y = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 172) b:N^Fe  
        人物坐标 = 存储内存内容 [读坐标_计次] + 168 Tns?mQ  
        人物像素坐标 = 存储内存内容 [读坐标_计次] + 116 b &\3ps  
        返回 (真) /e-ka{WS  
    .如果真结束 b*I&k":  
.计次循环尾 () F/Rng'l  
返回 (假) {] t\`fjrg  
.子程序 取人物状态, 逻辑型 t9Enk!@  
.如果真 (人物坐标 = 0) \_*?R,$3Y,  
    取人物坐标 () { ()p%#*  
.如果真结束 8ktjDs$=.:  
.如果真 (读内存整数型 (进程ID, 人物坐标 - 56) = 3) 4*p_s8> >  
    返回 (真) ?D*Hl+iu  
.如果真结束 <Um1h:^   
返回 (假) -Z`(? k  
.子程序 取地图编号, 整数型 mhHA!:Y  
.局部变量 存储内存内容, 整数型, , "0" "?2  
.局部变量 读坐标_计次, 整数型 ifJv~asp   
.如果真 (取反 (地图编号 = 0)) rE1np^z7  
    返回 (读内存整数型 (进程ID, 地图编号)) 'Yaf\Hp  
.如果真结束 JEK%yMj  
内存搜索 (进程ID, 到字节集 (288056328), 存储内存内容) Gx(KN57D  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) {<- ouD  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 60) = 288056308) 3X-{2R/ 3  
        地图编号 = 存储内存内容 [读坐标_计次] + 60 KRnB[$3F1  
        返回 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 60)) /ctaAQDUh\  
    .如果真结束 Q8}TNJsU  
.计次循环尾 () TRr4`y%  
返回 (0) .v #0cQX+.  
附件设置隐藏,需要回复后才能看到!
离线殇情

只看楼主 沙发  发表于: 2012-03-12
谢谢分享~~~~~~~~~~~~~~~···
离线myredns

只看楼主 板凳  发表于: 2012-03-13
            
离线q846121931

只看楼主 地板  发表于: 2012-03-14
学习
离线zxccxzzxc

只看楼主 4楼 发表于: 2012-04-17
有意思~!!!!
离线xiao水滴

只看楼主 5楼 发表于: 2012-04-17
无名社区 —打造专业游戏论坛 取小二坐标 pwm ]2}+  
r=u>TA$  
学习下 支持·······················
-------------------------
离线五渡

只看楼主 6楼 发表于: 2012-05-02
学习支持一下
离线supergirl520

发帖
11
只看楼主 7楼 发表于: 2012-05-08
学习学些。。。
离线hnscxh2012

只看楼主 8楼 发表于: 2012-05-28
强大,学学习习
离线deqdoff

只看楼主 9楼 发表于: 2012-06-04
Re:梦幻西游脚本E语言源码下载
快速回复
限80 字节
批量上传需要先选择文件,再选择上传
 
上一个 下一个