• 695阅读
  • 5回复

[娱乐工具]CSGO骨骼透视等多功能辅助源码 [复制链接]

上一主题 下一主题
离线清风入梦

 
发帖
1412

只看楼主 道具中心使用道具 楼主  发表于: 2018-12-21
CSGO骨骼透视等多功能辅助源码 g/V C$I!'  
  1. .版本 2
  2. .子程序 绘制循环
  3. .局部变量 ViewWorld, 小数型, , "4,4"
  4. .局部变量 ViewW, 小数型
  5. .局部变量 i, 整数型
  6. .局部变量 对象指针, 整数型
  7. .局部变量 对象坐标, D3D坐标
  8. .局部变量 自己坐标, D3D坐标
  9. .局部变量 对象血量, 整数型
  10. .局部变量 相机X, 整数型
  11. .局部变量 相机Y, 整数型
  12. .局部变量 相机Y2, 整数型
  13. .局部变量 BoxH, 整数型
  14. .局部变量 距离, 整数型
  15. .局部变量 自己阵营, 整数型
  16. .局部变量 自己指针, 整数型
  17. .局部变量 是否敌人阵营, 整数型
  18. .局部变量 head, 屏幕范围
  19. .局部变量 自瞄鼠标, D2D坐标
  20. .局部变量 鼠标角度, D2D坐标
  21. .局部变量 瞄准对象, 整数型
  22. .局部变量 瞄准坐标, 整数型
  23. .局部变量 鼠标x地址, 整数型
  24. .局部变量 鼠标y地址, 整数型
  25. .局部变量 瞄准位置, 整数型
  26. .局部变量 x坐标, 整数型
  27. .局部变量 y坐标, 整数型
  28. .局部变量 骨骼, 整数型
  29. .局部变量 敌人骨骼地址, 整数型
  30. .局部变量 敌人骨骼地址2, 整数型
  31. .局部变量 相机Z, 整数型
  32. .局部变量 缩放比例, 整数型
  33. .局部变量 自瞄对象, 整数型
  34. .局部变量 自瞄角度, D2D坐标
  35. ReadProcessMemory_小数型 (进程句柄, 矩阵基址, ViewWorld [1] [1], 64, 0)
  36. 视角宽 = 窗口宽度 ÷ 2
  37. 视角高 = 窗口高度 ÷ 2
  38. 自己指针 = 读内存整数型 (PID, 对象基址)
  39. 自己阵营 = 读内存整数型 (PID, 自己指针 + 244)
  40. 自己坐标 = 取自己坐标 ()
  41. .计次循环首 (80, i)
  42.     对象指针 = 读内存整数型 (PID, 对象基址 + i × 8)
  43.     敌人骨骼地址 = 读内存整数型 (PID, 对象指针 + 十六到十 (“26A8”))
  44.     是否敌人阵营 = 读内存整数型 (PID, 对象指针 + 244)
  45.     对象血量 = 读内存整数型 (PID, 对象指针 + 256)
  46.     .如果真 (自己阵营 = 是否敌人阵营)
  47.         到循环尾 ()
  48.     .如果真结束
  49.     .如果真 (对象血量 ≤ 0)
  50.         到循环尾 ()
  51.     .如果真结束
  52.     .如果真 (对象血量 > 100)
  53.         到循环尾 ()
  54.     .如果真结束
  55.     对象坐标.x = 读内存小数型 (PID, 对象指针 + 172)
  56.     对象坐标.y = 读内存小数型 (PID, 对象指针 + 176)
  57.     对象坐标.z = 读内存小数型 (PID, 对象指针 + 180)
  58.     ViewW = ViewWorld [4] [1] × 对象坐标.x + ViewWorld [4] [2] × 对象坐标.y + ViewWorld [4] [3] × 对象坐标.z + ViewWorld [4] [4]
  59.     .如果真 (ViewW < 0)
  60.         到循环尾 ()
  61.     .如果真结束
  62.     ViewW = 1 ÷ ViewW
  63.     相机X = 视角宽 + (ViewWorld [1] [1] × 对象坐标.x + ViewWorld [1] [2] × 对象坐标.y + ViewWorld [1] [3] × 对象坐标.z + ViewWorld [1] [4]) × ViewW × 视角宽
  64.     相机Y = 视角高 - (ViewWorld [2] [1] × 对象坐标.x + ViewWorld [2] [2] × 对象坐标.y + ViewWorld [2] [3] × (对象坐标.z + 75) + ViewWorld [2] [4]) × ViewW × 视角高
  65.     相机Y2 = 视角高 - (ViewWorld [2] [1] × 对象坐标.x + ViewWorld [2] [2] × 对象坐标.y + ViewWorld [2] [3] × (对象坐标.z - 5) + ViewWorld [2] [4]) × ViewW × 视角高
  66.     BoxH = 相机Y2 - 相机Y
  67.     处理事件 ()
  68.     距离 = 计算距离 (自己坐标, 对象坐标)
  69.     head.X = 相机X - BoxH ÷ 4
  70.     head.Y = 相机Y
  71.     head.W = 到整数 (BoxH ÷ 2)
  72.     .如果真 (开启方框)
  73.         绘制矩形 (相机X - (相机Y2 - 相机Y) ÷ 4, 相机Y, (相机Y2 - 相机Y) ÷ 2, 相机Y2 - 相机Y, #艳青, 1)
  74.     .如果真结束
  75.     .如果真 (开启距离)
  76.         描边文本 (相机X - (相机Y2 - 相机Y) ÷ 4, 相机Y - 24, “[距离]:” + 到文本 (距离) + “米”, #红色)
  77.     .如果真结束
  78.     .如果真 (开启射线)
  79.         绘制直线 (视角宽, 0, 相机X - BoxH ÷ 4 + BoxH ÷ 2 ÷ 2, 相机Y, 1, #红色)
  80.     .如果真结束
  81.     .如果真 (血量类型 = 1)
  82.         绘制文本 (相机X - (相机Y2 - 相机Y) ÷ 4, 相机Y, 到文本 (对象血量) + “Hp”, #红色)
  83.     .如果真结束
  84.     .如果真 (血量类型 = 2)
  85.         head.H = (相机Y - 相机Y2) ÷ 10
  86.         横向血条 (head, 对象血量, #绿色)
  87.     .如果真结束
  88.     .如果真 (血量类型 = 3)
  89.         head.H = 相机Y2 - 相机Y
  90.         竖向血条 (head, 对象血量, #绿色)
  91.     .如果真结束
  92.     .如果真 (血量类型 = 4)
  93.     .如果真结束
  94.     .如果真 (骨骼透视)
  95.         敌人骨骼地址2 = 敌人骨骼地址 + i × 48 + 12
  96.         .如果真 (自己阵营 = 是否敌人阵营)
  97.             到循环尾 ()
  98.         .如果真结束
  99.         对象坐标.x = 读内存小数型 (PID, 敌人骨骼地址2)
  100.         对象坐标.y = 读内存小数型 (PID, 敌人骨骼地址2 + 16)
  101.         对象坐标.z = 读内存小数型 (PID, 敌人骨骼地址2 + 32)
  102.         相机Z = ViewWorld [3] [1] × 对象坐标.x + ViewWorld [3] [2] × 对象坐标.y + ViewWorld [3] [3] × 对象坐标.z + ViewWorld [3] [4]
  103.         缩放比例 = 1 ÷ 相机Z
  104.         .如果真 (相机Z < 0)
  105.             到循环尾 ()
  106.         .如果真结束
  107.         相机X = 视角宽 + (ViewWorld [1] [1] × 对象坐标.x + ViewWorld [1] [2] × 对象坐标.y + ViewWorld [1] [3] × 对象坐标.z + ViewWorld [1] [4]) × 缩放比例 × 视角宽
  108.         相机Y = 视角高 - (ViewWorld [2] [1] × 对象坐标.x + ViewWorld [2] [2] × 对象坐标.y + ViewWorld [2] [3] × 对象坐标.z + ViewWorld [2] [4]) × 缩放比例 × 视角高
  109.         .如果真 (是否敌人阵营 = 2)
  110.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 38, 7)  ' 恐怖分子骨骼
  111.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 38, 3)
  112.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 74, 3)
  113.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 74, 75)
  114.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 3, 67)
  115.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 67, 68)
  116.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 38, 36)
  117.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 38, 64)
  118.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 64, 40)
  119.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 40, 63)
  120.         .如果真结束
  121.         .如果真 (是否敌人阵营 = 3)
  122.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 74, 73)  ' 警察骨骼
  123.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 73, 3)
  124.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 6, 3)
  125.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 6, 7)
  126.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 83, 82)
  127.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 82, 3)
  128.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 41, 64)
  129.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 65, 41)
  130.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 6, 65)
  131.             绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 6, 36)
  132.         .如果真结束
  133.         绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 12, 35)
  134.         绘制骨骼直线 (ViewWorld, 敌人骨骼地址, 36, 12)
  135.         绘制骨骼圆形 (ViewWorld, 敌人骨骼地址, 8)
  136.     .如果真结束
  137. .计次循环尾 ()
nb?bx{M  
F~RUb&*/<  
本部分内容设定了隐藏,需要回复后才能看到
离线ak47mmd

发帖
16

只看楼主 沙发  发表于: 2018-12-21
可以可以可以

发帖
115

只看楼主 板凳  发表于: 2018-12-26
5HOhk"  
guFR5>-L  
无名过客 N#ex2c  
发帖 ,[cWG)-  
5 45ct*w  
加关注 &;%+Hduc  
发消息 g:f0K2)\r:  
%iJ6;V 4  
?$r+#'asd(  
]~a!O  
只看楼主 QjZ}*p  
沙发  发表于: 12-21 QP\vN|r  
{P = {)  
L;BYPZR  
P *%bG 4  
可以可以可以 Ulktd^A\  
离线jiangsijie00

发帖
83

只看楼主 地板  发表于: 05-09
骨骼透视等多功能辅助源码
离线xhw9

发帖
690

只看楼主 4楼 发表于: 05-09
加关注 , 发消息
离线zxc6634


只看楼主 5楼 发表于: 06-26
谢谢大佬啊
快速回复
限80 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个